Author Topic: Brammo Enertia won't decelerate  (Read 203 times)

Zenkouki

  • Newbie
  • *
  • Posts: 2
    • View Profile
Brammo Enertia won't decelerate
« on: May 18, 2017, 05:43:24 PM »
I posted this on a different forum until i got approved by admin. If there is any advice on repairing this myself please let me know. Or if anyone knows where there's a place who will service in Northern california near San Jose.

Thanks

Gotta 2009 Brammo Enertia. Going under 15mph everything is ok, but anything faster than 15mph the bike won't coast. throttle grip springs back just fine, but the bike stays at the same speed and even slowly accelerates.

kwh does not drop either.

no mods except rear led signal lights.

is it the throttle? the motor? the firmware?

HELP!


Brammofan

  • Administrator
  • Brammovangelist
  • *****
  • Posts: 3011
  • Following the momentum of Enertia
    • View Profile
    • Brammofan Blog
    • Email
Re: Brammo Enertia won't decelerate
« Reply #1 on: May 18, 2017, 09:57:32 PM »
I asked some of my Brammo contacts. Hope they can help.

Sorry about your forum application falling through the cracks.
Follow me on Twitter at www.twitter.com/brammofan

Brammofan

  • Administrator
  • Brammovangelist
  • *****
  • Posts: 3011
  • Following the momentum of Enertia
    • View Profile
    • Brammofan Blog
    • Email
Re: Brammo Enertia won't decelerate
« Reply #2 on: May 19, 2017, 02:27:45 PM »
All I heard back was that the motor needs to be recalibrated. The problem is that no one seems to know where you can get that work performed.
Follow me on Twitter at www.twitter.com/brammofan

Zenkouki

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Brammo Enertia won't decelerate
« Reply #3 on: May 29, 2017, 09:31:06 PM »
If i can't fix it myself and i can't find a serivce place, can i just buy a used motor an replace it?